请选择 进入手机版 | 继续访问电脑版

RouterOS修改VRRP的MAC地址的方法

[复制链接]
查看77 | 回复0 | 2019-5-7 20:15:22 | 显示全部楼层 |阅读模式
RouterOS(以下简称ROS)的vrrp的mac地址是固定的,不能修改,一般都是00:00:5E:00:01:01开始,所以对于很多运营商来说只要封掉00:00:5E:00:xx:xx段MAC就可以封掉多拨。
对于实体机ROS来说,可以通过Bridge的方法来修改vrrp mac地址,网上也一般是这种方法。

操作方法:
一、建一个外网的bridge。(这边演示ether3是外网网卡)
Winbox -> Bridge -> +  -> OK(默认就可以)
Ports -> + -> Interface选择外网网口,这边是ether3,确定

  1. /interface bridge add name=bridge1
  2. /interface bridge port add bridge=bridge1 interface=ether3
复制代码


二、设置vrrp以及pppoe拨号连接
参考我以前的文章RouterOS通过VRRP实现单线多拨以及PCC负载均衡中的设置,这边就不详细写了

  1. /interface vrrp
  2. add interface=bridge1 name=vrrp1 vrid=1
  3. add interface=bridge1 name=vrrp2 vrid=2
  4. add interface=bridge1 name=vrrp3 vrid=3

  5. /interface pppoe-client
  6. add interface=vrrp1 name=pppoe-out1 password=xxxx user=xxxx
  7. add interface=vrrp2 name=pppoe-out2 password=xxxx user=xxxx
  8. add interface=vrrp3 name=pppoe-out3 password=xxxx user=xxxx

  9. /ip address
  10. add address=192.168.10.254/24 interface=bridge1 network=192.168.10.0
  11. add address=192.168.10.1/24 interface=vrrp1 network=192.168.10.0
  12. add address=192.168.10.2/24 interface=vrrp2 network=192.168.10.0
  13. add address=192.168.10.3/24 interface=vrrp3 network=192.168.10.0
复制代码

三、通过Bridge MAC NAT来修改vrrp的mac地址
1、首先开启Bridge的防火墙
Bridge -> Settings,勾上Use IP Firewall,点击ok
2、把vrrp修改为你需要的mac地址,有几条vrrp做几条(这边只做一条)
vrrp1的mac地址是00:00:5E:00:01:01,我拨号需要的mac地址是C49:87:44:03:63
Bridge -> NAT -> +,Chain选择 srcnat,Src. Mac Address地址填入vrrp1的mac地址00:00:5E:00:01:01,Src. Mac Mask默认即可
点击Action选项卡,Action选择src-nat,To Mac Address填入需要的mac地址C49:87:44:03:63,确定
Bridge -> NAT -> +,Chain选择 dstnat,Dst. Mac Address地址填入需要的mac地址C49:87:44:03:63,Dst. Mac Mask默认即可
点击Action选项卡,Action选择dst-nat,To Mac Address填入vrrp1的mac地址00:00:5E:00:01:01,确定

  1. /interface bridge settings set use-ip-firewall=yes
  2. /interface bridge nat
  3. add action=dst-nat chain=dstnat dst-mac-address=C4:D9:87:44:03:63/FF:FF:FF:FF:FF:FF to-dst-mac-address=00:00:5E:00:01:01
  4. add action=src-nat chain=srcnat src-mac-address=00:00:5E:00:01:01/FF:FF:FF:FF:FF:FF to-src-mac-address=C4:D9:87:44:03:63
复制代码


四、查看MAC地址
无法在本地查看PPPoE的拨号MAC地址。我这边通过电信的智宽生活可以看到mac地址,发现已经更新成我自己设置的mac地址

回复

使用道具 举报

*滑动验证:
您需要登录后才可以回帖 登录 | 立即注册

本版积分规则